summary refs log tree commit diff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-01-21 23:05:59 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-22 13:09:25 +0100
commite9d0c00aa260b59b6c88dfa6d253b87511941052 (patch)
tree49f7085e2408ef0be9bd9eb343983fa9f53e48cc
parent898c265013879fbfd7f503673bcc955197b3634c (diff)
downloadguix-e9d0c00aa260b59b6c88dfa6d253b87511941052.tar.gz
gnu: Add rust-chacha20poly1305-0.9.
* gnu/packages/crates-io.scm (rust-chacha20poly1305-0.9): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a2c5580015..417993aa82 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9310,6 +9310,38 @@ XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
 @code{rand_core-compatible} RNGs based on those ciphers.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-chacha20poly1305-0.9
+  (package
+    (name "rust-chacha20poly1305")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "chacha20poly1305" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0alawaaakczsll1b98qf4m6r6kfaw28506ljvsysjyjz3mnyv11v"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-aead" ,rust-aead-0.4)
+        ("rust-chacha20" ,rust-chacha20-0.8)
+        ("rust-cipher" ,rust-cipher-0.3)
+        ("rust-poly1305" ,rust-poly1305-0.7)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-aead" ,rust-aead-0.4))))
+    (home-page "https://github.com/RustCrypto/AEADs")
+    (synopsis
+     "Pure Rust implementation of ChaCha20Poly1305 Authenticated Encryption")
+    (description
+     "Pure Rust implementation of the ChaCha20Poly1305 Authenticated
+Encryption with Additional Data Cipher (RFC 8439) with optional
+architecture-specific hardware acceleration.  Also contains implementations of
+the XChaCha20Poly1305 extended nonce variant of ChaCha20Poly1305, and the
+reduced-round ChaCha8Poly1305 and ChaCha12Poly1305 lightweight variants.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-chalk-derive-0.75
   (package
     (name "rust-chalk-derive")