summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:52:10 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commitef52a9cad3ffd9d2260a40027a9735d17a7c9506 (patch)
tree81160e5e7ee57ef0a41abc9514edf03faa45311b
parentdaf2e151879f1e8baf10100e83322d811c576dea (diff)
downloadguix-ef52a9cad3ffd9d2260a40027a9735d17a7c9506.tar.gz
gnu: Add texlive-latex-rerunfilecheck.
* gnu/packages/tex.scm (texlive-latex-rerunfilecheck): New public variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 20eb7b6f0e..4ebc2512b2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3173,6 +3173,28 @@ arrows; record information about document class(es) used; and many more.")
 (define-public texlive-latex-oberdiek
   (deprecated-package "texlive-latex-oberdiek" texlive-oberdiek))
 
+(define-public texlive-latex-rerunfilecheck
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-rerunfilecheck"
+              '("/doc/latex/rerunfilecheck/"
+                "/tex/latex/rerunfilecheck/")
+              (base32
+               "1myz0d5bxhxvl4220ikywh921qld8n324kk9kscqbc5iw4063g56")
+              #:trivial? #t))
+    (propagated-inputs
+     `(("texlive-generic-infwarerr" ,texlive-generic-infwarerr)
+       ("texlive-generic-uniquecounter" ,texlive-generic-uniquecounter)
+       ("texlive-latex-atveryend" ,texlive-latex-atveryend)
+       ("texlive-latex-kvoptions" ,texlive-latex-kvoptions)
+       ("texlive-latex-pdftexcmds" ,texlive-latex-pdftexcmds)))
+    (home-page "https://www.ctan.org/pkg/rerunfilecheck")
+    (synopsis "Checksum based rerun checks on auxiliary files")
+    (description
+     "This package provides additional rerun warnings if some auxiliary
+files have changed.  It is based on MD5 checksum, provided by pdfTeX.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-latex-tools
   (package
     (name "texlive-latex-tools")