summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 10:52:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 10:52:45 +0100
commitf1fd313e486491caf1ff5874810f2ee06091e825 (patch)
tree4dce85e8c59d9681ffda5f1ac974ab9589b784e0
parente1cb787870d6dd156ce02d4d7c32235e17b6a233 (diff)
downloadguix-f1fd313e486491caf1ff5874810f2ee06091e825.tar.gz
gnu: gnome-shell: Do not wrap in LD_LIBRARY_PATH.
Fixes <https://bugs.gnu.org/37123>.

* gnu/packages/gnome.scm (gnome-shell)[arguments]: Remove LD_LIBRARY_PATH from
wrapper.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5f99616571..35ac02272a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8836,15 +8836,7 @@ properties, screen resolution, and other GNOME parameters.")
                    (gi-typelib-path  (getenv "GI_TYPELIB_PATH"))
                    (python-path      (getenv "GUIX_PYTHONPATH")))
                (wrap-program (string-append out "/bin/gnome-shell")
-                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
-                 ;; FIXME: gnome-shell loads these libraries with unqualified
-                 ;; names only, so they need to be on LD_LIBRARY_PATH.  The
-                 ;; alternative might be to patch gnome-shell.
-                 `("LD_LIBRARY_PATH" ":" prefix
-                   ,(map (lambda (pkg)
-                           (string-append (assoc-ref inputs pkg) "/lib"))
-                         '("gdk-pixbuf"
-                           "gnome-bluetooth" "librsvg" "libgweather"))))
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
                (for-each
                 (lambda (prog)
                   (wrap-program (string-append out "/bin/" prog)