summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-07-22 09:29:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-07-22 09:29:19 +0200
commitf23891b71c9cfb8da30bb2f0affe3e7d329dd858 (patch)
tree89a8a0723cf5d9996f1bc40ea74f28f60b6c14a8
parentb4a0f6283266cdc681e2f3bc93a558f5dc2a26ea (diff)
downloadguix-f23891b71c9cfb8da30bb2f0affe3e7d329dd858.tar.gz
gnu: sdr++: Enable airspy support.
* gnu/packages/radio.scm (sdr++)[inputs]: Add airspy.
  [arguments]: Update 'configure-flags'.
-rw-r--r--gnu/packages/radio.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index fef39996c8..583516a81d 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2601,7 +2601,8 @@ various hardware.")
       (native-inputs
        (list pkg-config))
       (inputs
-       (list airspyhf
+       (list airspy
+             airspyhf
              alsa-lib
              codec2
              fftwf
@@ -2618,8 +2619,7 @@ various hardware.")
              (list zstd "lib")))
       (arguments
        (list #:tests? #f ; No test suite.
-             #:configure-flags #~(list "-DOPT_BUILD_AIRSPY_SOURCE=OFF"
-                                       "-DOPT_BUILD_PLUTOSDR_SOURCE=OFF"
+             #:configure-flags #~(list "-DOPT_BUILD_PLUTOSDR_SOURCE=OFF"
                                        "-DOPT_BUILD_M17_DECODER=ON")
              #:phases
              #~(modify-phases %standard-phases