summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-06-13 13:10:43 +0000
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-25 16:04:07 -0400
commitf4d7610a9b86745277782b0677507486f8e88d66 (patch)
tree6bd166be4d398f761f720c4677eb55153e1e8e1d
parent9ff1e7652a407b88a3eeeab6a67261f6fee40807 (diff)
downloadguix-f4d7610a9b86745277782b0677507486f8e88d66.tar.gz
gnu: mesa: Fix VDPAU drivers path.
The VDPAU_DRIVER_PATH environment variable must contain only one directory.

* gnu/packages/gl.scm (mesa)[native-search-paths]: Fix specification for
  VDPAU_DRIVER_PATH.

Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/packages/gl.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1691086e1a..d42903cc8f 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -518,6 +518,7 @@ svga,swrast,virgl")))
      (list (search-path-specification
             ;; Ensure the Mesa VDPAU drivers can be found.
             (variable "VDPAU_DRIVER_PATH")
+            (separator #f)
             (files '("lib/vdpau")))))
     (home-page "https://mesa3d.org/")
     (synopsis "OpenGL and Vulkan implementations")