summary refs log tree commit diff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-16 10:42:43 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:07 +0200
commitf88a7d82c7daf84d074a14acbc9fad75b21dbe58 (patch)
treef4d59abb47f018b95603d5a88a35a422fa81a117
parenta0d576bf2695a9a0c1058b73b15eeeb40fceba87 (diff)
downloadguix-f88a7d82c7daf84d074a14acbc9fad75b21dbe58.tar.gz
gnu: Add emacs-heaven-and-hell.
* gnu/packages/emacs-xyz.scm (emacs-heaven-and-hell): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6eb451e1bb..3f2e168d32 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27132,6 +27132,26 @@ text-tree applications inside GNU Emacs.  It consists of 2 subprojects:
 @command{ztree-diff}).")
       (license license:gpl3))))
 
+(define-public emacs-heaven-and-hell
+  (package
+    (name "emacs-heaven-and-hell")
+    (version "0.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/valignatev/heaven-and-hell")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bgs638nsn9hyvc9wbc2jpqm5i3hblld1mhmf0h9z0j6fjr0aapx"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/valignatev/heaven-and-hell")
+    (synopsis "Easily toggle light/dark themes in Emacs")
+    (description "This package makes the process of switching between
+light and dark themes as easy as hitting a single keystroke.")
+    (license license:expat)))
+
 (define-public emacs-helm-org-contacts
   (let ((commit "741eca6239684950219c9a12802386a132491b8c")
         (revision "2"))