summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-14 18:10:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 18:31:35 +0100
commit404efac48bbb96ce6852df2059001cbfa22a3cfb (patch)
tree5467808518795b776f90df00c977364387fd7ced
parentf63495d31bf5acad00b6ee5f44a0553a67ee91fb (diff)
downloadguix-404efac48bbb96ce6852df2059001cbfa22a3cfb.tar.gz
gnu: python-boot0: Do not inherit source snippet from python.
This is in preparation for Python 3.8 which requires changes.

* gnu/packages/commencement.scm (python-boot0)[source]: Copy modules and
snippet from PYTHON instead of inheriting.
-rw-r--r--gnu/packages/commencement.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 928819db6e..0f7ca24865 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1885,13 +1885,21 @@ the bootstrap environment."
     (version "3.5.7")
     (source (bootstrap-origin
              (origin
-               (inherit (package-source python))
+               (method url-fetch)
                (uri (string-append "https://www.python.org/ftp/python/"
                                    version "/Python-" version ".tar.xz"))
-               (patches '())
                (sha256
                 (base32
-                 "1p67pnp2ca5przx2s45r8m55dcn6f5hsm0l4s1zp7mglkf4r4n18")))))
+                 "1p67pnp2ca5przx2s45r8m55dcn6f5hsm0l4s1zp7mglkf4r4n18"))
+               (modules '((guix build utils)))
+               (snippet
+                '(begin
+                   ;; Delete the bundled copy of libexpat.
+                   (delete-file-recursively "Modules/expat")
+                   (substitute* "Modules/Setup.dist"
+                     ;; Link Expat instead of embedding the bundled one.
+                     (("^#pyexpat.*") "pyexpat pyexpat.c -lexpat\n"))
+                   #t)))))
     (inputs
      `(,@(%boot0-inputs)
        ("expat" ,expat-sans-tests)))              ;remove OpenSSL, zlib, etc.