summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:42:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:30:08 +0300
commit5b1a9e07596759b4cb66b732e7661ecd6ec8a122 (patch)
tree16970aafe73f27e9e07756125cd00ab4f543290e
parent04eba1d046aa058ef7a64b8b70caf6da13176667 (diff)
downloadguix-5b1a9e07596759b4cb66b732e7661ecd6ec8a122.tar.gz
gnu: python-django-allauth: Update to 0.40.0.
* gnu/packages/django.scm (python-django-allauth): Update to 0.40.0.
[arguments]: Remove 'skip-test-requiring-network-access phase. Adjust
custom 'check phase.
-rw-r--r--gnu/packages/django.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 69fedf7612..926d6d6dbd 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -392,36 +392,23 @@ them do this.")
 (define-public python-django-allauth
   (package
     (name "python-django-allauth")
-    (version "0.39.1")
+    (version "0.40.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "django-allauth" version))
        (sha256
         (base32
-         "17l0acpr3cihdndzccjhgv58f9z170v2qwx7w0b8w6235x646i24"))))
+         "12f5gjidcpb7a0d1f601k0c5dcdmb6fg9sfn7xn5j8zfsg29y63a"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         ;; TODO: Tagging the tests requiring the web could be done upstream.
-         (add-before 'check 'skip-test-requiring-network-access
-           (lambda _
-             (substitute* "allauth/socialaccount/providers/openid/tests.py"
-               (("import override_settings") "import tag, override_settings")
-               (("def test_login")
-                "@tag('requires-web')
-    def test_login"))))
          (replace 'check
            (lambda _
-             ;; TODO: investigate why this test fails
-             (delete-file "allauth/socialaccount/providers/cern/tests.py")
              (setenv "DJANGO_SETTINGS_MODULE" "test_settings")
-             (invoke "django-admin"
-                     "test"
-                     "allauth"
-                     "--verbosity=2"
-                     "--exclude-tag=requires-web"))))))
+             (invoke "django-admin" "test" "allauth.tests"
+                     "--pythonpath=."))))))
     (propagated-inputs
      `(("python-openid" ,python-openid)
        ("python-requests" ,python-requests)