summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:03:58 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commit6eb28ece007ba60166933b72c4ac69706cbf933b (patch)
tree7adaa7fc7f69b3b184d919caa15043d2e82fd717
parent269ef086224e77a4ff9933a1d9ce26a0fcfbed59 (diff)
downloadguix-6eb28ece007ba60166933b72c4ac69706cbf933b.tar.gz
gnu: Add ExtUtils-Config.
* gnu/packages/perl.scm (perl-extutils-config): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5e4ac07317..26b27d46b8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -300,6 +300,26 @@ import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
                               "Exporter-Lite-" version))
     (license (package-license perl))))
 
+(define-public perl-extutils-config
+  (package
+    (name "perl-extutils-config")
+    (version "0.008")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+                           "ExtUtils-Config-" version ".tar.gz"))
+       (sha256
+        (base32
+         "130s5zk4krrymbynqxx62g13jynnb7xi7vdpg65cw3b56kv08ldf"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/ExtUtils-Config")
+    (synopsis "Wrapper for perl's configuration")
+    (description "ExtUtils::Config is an abstraction around the %Config hash.
+By itself it is not a particularly interesting module by any measure, however
+it ties together a family of modern toolchain modules.")
+    (license (package-license perl))))
+
 (define-public perl-file-find-rule
   (package
     (name "perl-file-find-rule")