summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-02-08 22:05:26 +0100
committerJelle Licht <jlicht@fsfe.org>2023-02-20 16:58:51 +0100
commit9be0f4a403d5a805c52ec614ff9c06a01f36c5e1 (patch)
treeed0355ebf25f17b05ec1917d5bbc2048bc0aee39
parent608ba32d7f968bd1693096b4084724c8d4208266 (diff)
downloadguix-9be0f4a403d5a805c52ec614ff9c06a01f36c5e1.tar.gz
gnu: node-yazl: Ignore development dependencies.
* gnu/packages/node-xyz.scm (node-yazl)[arguments]<phases>: Explicitly patch
out development dependencies. Re-enable configure phase.
-rw-r--r--gnu/packages/node-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index d8939d1469..8740796a8c 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1588,10 +1588,9 @@ default set of parsers and bindings.")))
     (arguments
      '(#:tests? #f
        #:phases (modify-phases %standard-phases
-                  (replace 'configure
+                  (add-after 'patch-dependencies 'delete-dependencies
                     (lambda _
-                      (invoke "npm" "--offline" "--ignore-scripts" "install"
-                              "--production"))))))
+                      (delete-dependencies '("airtap" "bl" "istanbul" "yauzl")))))))
     (inputs (list node-buffer-crc32))
     (home-page "https://github.com/thejoshwolfe/yazl")
     (synopsis "Yet another zip library for node")