summary refs log tree commit diff
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2021-06-15 17:37:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-24 23:43:05 +0200
commitd3e8890613f62a6fc2620e544e34fc64ceb832e7 (patch)
treeb93e3588afcd14a192ff32e5de56ccdb6a5a5006
parent8a81ae61c183085b3a1edc4572d721ac5b2a581c (diff)
downloadguix-d3e8890613f62a6fc2620e544e34fc64ceb832e7.tar.gz
gnu: Add ausweisapp2.
* gnu/packages/security-token.scm (ausweisapp2): New variable.
* guix/licenses.scm (eupl1.2): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/security-token.scm49
-rw-r--r--guix/licenses.scm6
2 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 89783de965..49ca1dc01e 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
+;;; Copyright © 2021 Sergey Trofimov <sarg@sarg.org.ru>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,6 +35,7 @@
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system cargo)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system python)
@@ -56,6 +58,7 @@
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages perl)
@@ -720,3 +723,49 @@ an unprivileged user.")
 for interaction with Nitrokey Pro, Nitrokey Storage, and Librem Key
 devices.")
     (license license:gpl3+)))
+
+(define-public ausweisapp2
+  (package
+    (name "ausweisapp2")
+    (version "1.22.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
+                                  "/download/" version "/AusweisApp2-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("qtbase" ,qtbase-5)
+       ("qtsvg" ,qtsvg)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtwebsockets" ,qtwebsockets)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("pcsc-lite" ,pcsc-lite)
+       ("openssl" ,openssl)))
+    (arguments
+     `(#:modules ((guix build cmake-build-system)
+                  (guix build qt-utils)
+                  (guix build utils))
+       #:imported-modules (,@%cmake-build-system-modules
+                           (guix build qt-utils))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-qt
+           (lambda* (#:key outputs #:allow-other-keys)
+             (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2"))))))
+    (home-page "https://github.com/Governikus/AusweisApp2")
+    (synopsis
+     "Authentication program for German ID cards and residence permits")
+    (description
+     "This application is developed and issued by the German government to be
+used for online authentication with electronic German ID cards and residence
+titles.  To use this app, a supported RFID card reader or NFC-enabled smart
+phone is required.")
+    (license license:eupl1.2)))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index e7457799ce..3affe1e920 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -56,6 +56,7 @@
             edl1.0
             epl1.0
             epl2.0
+            eupl1.2
             expat
             freetype
             freebsd-doc
@@ -307,6 +308,11 @@ at URI, which may be a file:// URI pointing the package's tree."
            "https://www.eclipse.org/legal/epl-2.0/"
            "https://www.gnu.org/licenses/license-list#EPL2"))
 
+(define eupl1.2
+  (license "EUPL 1.2"
+           "https://directory.fsf.org/wiki/License:EUPL-1.2"
+           "https://www.gnu.org/licenses/license-list#EUPL-1.2"))
+
 (define expat
   (license "Expat"
            "http://directory.fsf.org/wiki/License:Expat"