summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:50:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:50:11 -0400
commit5dc5d6fa8136f067c85295d88018a7cd8b7cfe40 (patch)
treedfd584169b51a2e611b153dd33a439521f023f12
parent3c6e220d8100281074c414a43c1efe9a01b53771 (diff)
parent16f535713ed91c26817dc645a5b920b5e6f3d3f4 (diff)
downloadguix-5dc5d6fa8136f067c85295d88018a7cd8b7cfe40.tar.gz
Merge branch 'master' into staging
-rw-r--r--gnu/packages/samba.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 35d15667b6..7993b33f8c 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -290,6 +290,8 @@ Samba is an important component to seamlessly integrate Linux/Unix Servers and
 Desktops into Active Directory environments using the winbind daemon.")
     (license license:gpl3+)))
 
+;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; susceptible to changes in the free one.
 (define-public samba/fixed
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
@@ -301,7 +303,21 @@ Desktops into Active Directory environments using the winbind daemon.")
         (uri (string-append "https://download.samba.org/pub/samba/stable/"
                             "samba-" version ".tar.gz"))
         (sha256
-         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si")))))))
+         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si"))))
+     (native-inputs
+      (list perl-parse-yapp
+            pkg-config
+            python-cryptography         ;for krb5 tests
+            python-dnspython
+            python-iso8601
+            python-markdown
+            rpcsvc-proto                ;for 'rpcgen'
+            python-pyasn1               ;for krb5 tests
+            ;; For generating man pages.
+            docbook-xml-4.2
+            docbook-xsl
+            libxslt
+            libxml2)))))
 
 (define-public talloc
   (package