summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-19 14:07:13 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-19 17:28:46 +0200
commita08cb3ca951cf9ebdea5258e6c34e2664877c363 (patch)
tree77ef57a987fafb0666d2255b834719b2db92aec2
parent49a1203d67a90a6a7ce4e4537697a6da96ceb213 (diff)
downloadguix-a08cb3ca951cf9ebdea5258e6c34e2664877c363.tar.gz
Remove (guix build rpath).
This file was unused and is now superseded by (guix build gremlin).

* guix/build/rpath.scm: Remove.
* Makefile.am (MODULES): Remove it.
-rw-r--r--Makefile.am1
-rw-r--r--guix/build/rpath.scm59
2 files changed, 0 insertions, 60 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e91e1e558..09eaaf36e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -202,7 +202,6 @@ MODULES =					\
   guix/build/union.scm				\
   guix/build/profiles.scm			\
   guix/build/compile.scm			\
-  guix/build/rpath.scm				\
   guix/build/cvs.scm				\
   guix/build/svn.scm				\
   guix/build/syscalls.scm                       \
diff --git a/guix/build/rpath.scm b/guix/build/rpath.scm
deleted file mode 100644
index 75a1fef5ef..0000000000
--- a/guix/build/rpath.scm
+++ /dev/null
@@ -1,59 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix build rpath)
-  #:use-module (ice-9 popen)
-  #:use-module (ice-9 rdelim)
-  #:export (%patchelf
-            file-rpath
-            augment-rpath))
-
-;;; Commentary:
-;;;
-;;; Tools to manipulate the RPATH and RUNPATH of ELF binaries.  Currently they
-;;; rely on PatchELF.
-;;;
-;;; Code:
-
-(define %patchelf
-  ;; The `patchelf' command.
-  (make-parameter "patchelf"))
-
-(define %not-colon
-  (char-set-complement (char-set #\:)))
-
-(define (file-rpath file)
-  "Return the RPATH (or RUNPATH) of FILE as a list of directory names, or #f
-on failure."
-  (let* ((p (open-pipe* OPEN_READ (%patchelf) "--print-rpath" file))
-         (l (read-line p)))
-    (and (zero? (close-pipe p))
-         (string-tokenize l %not-colon))))
-
-(define (augment-rpath file dir)
-  "Add DIR to the front of the RPATH and RUNPATH of FILE.  Return the new
-RPATH as a list, or #f on failure."
-  (let* ((rpath  (or (file-rpath file) '()))
-         (rpath* (cons dir rpath)))
-    (format #t "~a: changing RPATH from ~s to ~s~%"
-            file rpath rpath*)
-    (and (zero? (system* (%patchelf) "--set-rpath"
-                         (string-join rpath* ":") file))
-         rpath*)))
-
-;;; rpath.scm ends here