summary refs log tree commit diff
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2021-03-30 00:54:09 +0200
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-30 00:57:26 +0200
commit00c67375b17f4a4cfad53399d1918f2e7eba2c7d (patch)
tree7c3aa43290da63562bfb483c3ae02a83378f34d8
parentb20b45c6ce67593db9d446d066e02310671ad8d7 (diff)
downloadguix-00c67375b17f4a4cfad53399d1918f2e7eba2c7d.tar.gz
gnu: zstd: Fix tests on 32-bit architectures.
* gnu/packages/compression.scm (zstd)[arguments]<#:phases>: Add
'fix-tests-32bit.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/compression.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1a41e5ab8d..e28b78a3fa 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -32,6 +32,7 @@
 ;;; Copyright © 2020 Léo Le Bouter <lle-bout@zaclys.net>
 ;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1416,6 +1417,12 @@ or junctions, and always follows hard links.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-tests-32bit
+           ;; Remove when https://github.com/facebook/zstd/issues/2528 is fixed.
+           (lambda _
+             (substitute* "tests/playTests.sh"
+               (("roundTripTest -g8M \"19 -T0 --long\"")
+                "roundTripTest -g8M \"22 -T0 --long\""))))
          (add-after 'unpack 'remove-bogus-check
            (lambda _
              ;; lib/Makefile falsely claims that no .pc file can be created.