summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-11 18:10:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-13 14:14:41 +0200
commit0ace73f142ac9c8d8a5be9c0b24f4bb0d53cb0bb (patch)
tree102bffa90f6ad5c6ca03c5110c6d8992e1da9b38
parent954b3c8b6560eb193e7b629e7eb541e101f86167 (diff)
downloadguix-0ace73f142ac9c8d8a5be9c0b24f4bb0d53cb0bb.tar.gz
gnu: ALSA: Update to 1.1.9.
* gnu/packages/linux.scm (alsa-lib, alsa-utils, alsa-plugins): Update to 1.1.9.
* gnu/packages/pulseaudio.scm (pulseaudio)[arguments]: Add phase to adjust
ALSA header file name.
-rw-r--r--gnu/packages/linux.scm12
-rw-r--r--gnu/packages/pulseaudio.scm5
2 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0dfa2f173a..dbe7651001 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1073,7 +1073,7 @@ intercept and print the system calls executed by the program.")
 (define-public alsa-lib
   (package
     (name "alsa-lib")
-    (version "1.1.8")
+    (version "1.1.9")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -1081,7 +1081,7 @@ intercept and print the system calls executed by the program.")
                    version ".tar.bz2"))
              (sha256
               (base32
-               "1pxf0zkmps03l3zzd0fr828xhkg6a8hxljmbxzc2cyj2ls9kmp1w"))))
+               "0jwr9g4yxg9gj6xx0sb2r6wrdl8amrjd19hilkrq4rirynp770s8"))))
     (build-system gnu-build-system)
     (home-page "https://www.alsa-project.org/")
     (synopsis "The Advanced Linux Sound Architecture libraries")
@@ -1093,14 +1093,14 @@ MIDI functionality to the Linux-based operating system.")
 (define-public alsa-utils
   (package
     (name "alsa-utils")
-    (version "1.1.8")
+    (version "1.1.9")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://ftp.alsa-project.org/pub/utils/"
                                  name "-" version ".tar.bz2"))
              (sha256
               (base32
-               "1kx45yhrxai3k595yyqs4wj0p2n5b0c9mf0k36ljjf1bj8lgb6zx"))))
+               "0fi11b7r8hg1bdjw74s8sqx8rc4qb310jaj9lsia9labvfyjrpsx"))))
     (build-system gnu-build-system)
     (arguments
      ;; XXX: Disable man page creation until we have DocBook.
@@ -1147,14 +1147,14 @@ MIDI functionality to the Linux-based operating system.")
 (define-public alsa-plugins
   (package
     (name "alsa-plugins")
-    (version "1.1.8")
+    (version "1.1.9")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
                                  name "-" version ".tar.bz2"))
              (sha256
               (base32
-               "152r82i6f97gfilfgiax5prxkd4xlcipciv8ha8yrk452qbxyxvz"))))
+               "01zrg0h2jw9dlj9233vjsn916yf4f2s667yry6xsn8d57lq745qn"))))
     (build-system gnu-build-system)
     ;; TODO: Split libavcodec and speex if possible. It looks like they can not
     ;; be split, there are references to both in files.
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 7001a8137b..96d15bdf9c 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -154,6 +154,11 @@ rates.")
                                               (assoc-ref %outputs "out")
                                               "/lib/udev/rules.d"))
        #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'fix-alsa-include
+                    (lambda _
+                      (substitute* '("configure" "src/modules/alsa/alsa-ucm.h")
+                        (("use-case\\.h") "alsa/use-case.h"))
+                      #t))
                  (add-before 'check 'pre-check
                    (lambda _
                      ;; 'tests/lock-autospawn-test.c' wants to create a file