summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-24 13:30:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 10:02:54 +0200
commit0f9e0abd4fd15afb498ec8aa3ca10fdb8a9bc1c4 (patch)
treeacd07d7f299ae05aa2668575eb25a8a15d61a96e
parentcf2327ecc0e92ec28e8863bb35ff38d9ffaa0615 (diff)
downloadguix-0f9e0abd4fd15afb498ec8aa3ca10fdb8a9bc1c4.tar.gz
gnu: Add python-rcslice.
* gnu/packages/python-xyz.scm (python-rcslice): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1e4d04e069..c22718efaf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30402,3 +30402,29 @@ window managers.")
     (synopsis "Handle cyclic relations")
     (description "This package handles cyclic relations compared by value.")
     (license license:bsd-3)))
+
+(define-public python-rcslice
+  (package
+    (name "python-rcslice")
+    (version "1.1.0")
+    (source (origin
+              ;; Use git, as there are some test files missing from the PyPI
+              ;; release, see https://github.com/neurobin/rcslice/issues/1
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/neurobin/rcslice")
+                    ;; Releases are not tagged on github, see
+                    ;; https://github.com/neurobin/rcslice/issues/2
+                    (commit "1e1ef42cd262db76b67ded430630d5b499790f42")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lmhcgghh60kvdlx0cin1phhgfy9jivc6l0mb4ibnpa1x1md0zvv"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/neurobin/rcslice")
+    (synopsis "Slice a list of sliceables")
+    (description "This package provides Python module to slice a list of
+sliceables (1 indexed, both start and end index are inclusive).  Helps to
+slice file content line by line or column by column or a combination of
+both.")
+    (license license:bsd-3)))