summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-15 11:23:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-15 11:23:34 +0200
commit1ee9c40a76bbb1424c7a82912d40d4afd12bd38f (patch)
tree7cf880f85e7c7347df6cc797f7993aea116169b3
parent7a6f536bca769fa84db5a9f9b76c1b255673eb38 (diff)
downloadguix-1ee9c40a76bbb1424c7a82912d40d4afd12bd38f.tar.gz
gnu: rust-string-cache-0.8: Update to 0.8.4.
* gnu/packages/crates-io.scm (rust-string-cache-0.8): Update to 0.8.4.
[cargo-inputs]: Remove rust-lazy-static-1. Replace rust-phf-shared-0.8
with 0.10. Add rust-once-cell-1, rust-parking-lot-0.12.
-rw-r--r--gnu/packages/crates-io.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5d0923c8fd..83ae760cc1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56289,7 +56289,7 @@ configurable byte storage.")
 (define-public rust-string-cache-0.8
   (package
     (name "rust-string-cache")
-    (version "0.8.0")
+    (version "0.8.4")
     (source
       (origin
         (method url-fetch)
@@ -56298,13 +56298,14 @@ configurable byte storage.")
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "12i0synp8l0qpnzi5qki4pjq3jx28ykikyffjjjg6fsfxddwfh19"))))
+          "020ahbx93gp85s3k3k5c342j10ml0b77i4q4hri180xmlavr8d11"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-new-debug-unreachable" ,rust-new-debug-unreachable-1)
-        ("rust-phf-shared" ,rust-phf-shared-0.8)
+       (("rust-new-debug-unreachable" ,rust-new-debug-unreachable-1)
+        ("rust-once-cell" ,rust-once-cell-1)
+        ("rust-parking-lot" ,rust-parking-lot-0.12)
+        ("rust-phf-shared" ,rust-phf-shared-0.10)
         ("rust-precomputed-hash" ,rust-precomputed-hash-0.1)
         ("rust-serde" ,rust-serde-1))))
     (home-page "https://github.com/servo/string-cache")