summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-02-05 23:26:36 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-14 15:52:37 +0100
commit26d0f1ec3b871c8a1e0f67b9b55d5fc3d027bc83 (patch)
treee9bbfbedce847396d9a2e197baf4054dd692ec93
parentaff2ba67e21cd236a6cbf70ae483d527d4bed8ef (diff)
downloadguix-26d0f1ec3b871c8a1e0f67b9b55d5fc3d027bc83.tar.gz
gnu: Add cppcodec.
* gnu/packages/crates-io.scm (cppcodec): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/security-token.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index c71bb85843..63ac8e97be 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -748,6 +748,30 @@ an unprivileged user.")
     (description "This packate provides communication library for Nitrokey.")
     (license license:lgpl3+)))
 
+(define-public cppcodec
+  (package
+    (name "cppcodec")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tplgy/cppcodec")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0z39f8w0zvra874az0f67ck1al9kbpaidpilggbl8jnfs05010ck"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags (list "-DBUILD_TESTING=on")))
+    (native-inputs (list pkg-config qttools))
+    (inputs (list catch-framework2))
+    (home-page "https://github.com/tplgy/cppcodec")
+    (synopsis "Header library to encode/decode base64, base64url, etc.")
+    (description "This package provides library to encode/decode base64,
+base64url, base32, base32hex and hex.")
+    (license license:expat)))
+
 (define-public nitrocli
   (package
     (name "nitrocli")