summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-03 16:59:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-03 17:42:18 +0200
commit2bdc88fce75495496f1d7af65f1cadd1e5f51a66 (patch)
tree2aa6ea1638d273559f6203af41383c6bd81df444
parent83546785b2a2da0c7b0c54ac5eb1bf1d5872ebbf (diff)
downloadguix-2bdc88fce75495496f1d7af65f1cadd1e5f51a66.tar.gz
gnu: Add r-rbowtie2.
* gnu/packages/bioconductor.scm (r-rbowtie2): New variable.
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3800c2472e..823282397c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4179,3 +4179,26 @@ Currently only Affymetrix oligonucleotide analysis is supported.")
 This algorithm is based on the publication by Hart et al., 2013 (Pubmed ID
 24215113).")
     (license license:gpl3)))
+
+(define-public r-rbowtie2
+  (package
+    (name "r-rbowtie2")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "Rbowtie2" version))
+       (sha256
+        (base32
+         "045cmfwqzcj4zn6r16hkpmr5sd5y0mxvrs5yynf460fdz2p418cr"))))
+    (properties `((upstream-name . "Rbowtie2")))
+    (build-system r-build-system)
+    (inputs
+     `(("zlib" ,zlib)))
+    (home-page "https://bioconductor.org/packages/Rbowtie2/")
+    (synopsis "R wrapper for Bowtie2 and AdapterRemoval")
+    (description
+     "This package provides an R wrapper of the popular @code{bowtie2}
+sequencing reads aligner and @code{AdapterRemoval}, a convenient tool for
+rapid adapter trimming, identification, and read merging.")
+    (license license:gpl3+)))