summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 19:40:49 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 22:41:22 +0200
commit3cf8b3dc574c5c0e8df1b76b9349db197ba54333 (patch)
treea5082345d3b4a96f7a5f9b1bcb344c1e26dc4772
parent2ca34cc3bbf03bd67eecbcaecfb67823794b807b (diff)
downloadguix-3cf8b3dc574c5c0e8df1b76b9349db197ba54333.tar.gz
gnu: cmake-minimal: Update to 3.24.2.
* gnu/packages/patches/cmake-curl-certificates.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/cmake.scm (cmake-bootstrap): Update to 3.24.2
[source](patches): Use refreshed patch.
(cmake)[version, source]: Remove.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cmake.scm23
-rw-r--r--gnu/packages/patches/cmake-curl-certificates.patch41
3 files changed, 3 insertions, 62 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 86dbd51a0b..b09c887c8d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -971,7 +971,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/classpath-miscompilation.patch		\
   %D%/packages/patches/cling-use-shared-library.patch		\
   %D%/packages/patches/clucene-pkgconfig.patch			\
-  %D%/packages/patches/cmake-curl-certificates.patch		\
   %D%/packages/patches/cmake-curl-certificates-3.24.patch	\
   %D%/packages/patches/coda-use-system-libs.patch		\
   %D%/packages/patches/collectd-5.11.0-noinstallvar.patch		\
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7f51c02b8a..151b91bf12 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -152,7 +152,7 @@ using the CMake build system.")
 (define-public cmake-bootstrap
   (package
     (name "cmake-bootstrap")
-    (version "3.24.1")
+    (version "3.24.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://cmake.org/files/v"
@@ -160,8 +160,8 @@ using the CMake build system.")
                                   "/cmake-" version ".tar.gz"))
               (sha256
                (base32
-                "0ax83yfis1n74llqhckrbgzcp82pfwx039xs2dgq06nvlivy4ca9"))
-              (patches (search-patches "cmake-curl-certificates.patch"))))
+                "1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
+              (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -330,23 +330,6 @@ and workspaces that can be used in the compiler environment of your choice.")
   (package
     (inherit cmake-minimal)
     (name "cmake")
-    (version "3.24.2")
-    (source (origin
-              (inherit (package-source cmake-minimal))
-              (method url-fetch)
-              (uri (string-append "https://cmake.org/files/v"
-                                  (version-major+minor version)
-                                  "/cmake-" version ".tar.gz"))
-              (snippet (match (origin-snippet (package-source cmake-minimal))
-                         (('begin ('define 'preserved-files ('quote x))
-                                  rest ...)
-                          `(begin (define preserved-files
-                                    ',(cons "Utilities/cmelf" x))
-                                  ,@rest))))
-              (sha256
-               (base32
-                "1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
-              (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
     (outputs '("out" "doc"))
     (arguments
      (substitute-keyword-arguments (package-arguments cmake-minimal)
diff --git a/gnu/packages/patches/cmake-curl-certificates.patch b/gnu/packages/patches/cmake-curl-certificates.patch
deleted file mode 100644
index 8dd93de724..0000000000
--- a/gnu/packages/patches/cmake-curl-certificates.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-By default commands such as "ctest" would not look for certificates
-at all: <https://issues.guix.gnu.org/issue/37371>.
-
-This changes CMake such that commands honor SSL_CERT_FILE and SSL_CERT_DIR
-as well as /etc/ssl/certs.
-
-diff --git a/Source/cmCurl.cxx b/Source/cmCurl.cxx
-index 28ee24dfe9..6b2bb09ff5 100644
---- a/Source/cmCurl.cxx
-+++ b/Source/cmCurl.cxx
-@@ -2,10 +2,7 @@
-    file Copyright.txt or https://cmake.org/licensing for details.  */
- #include "cmCurl.h"
- 
--#if !defined(CMAKE_USE_SYSTEM_CURL) && !defined(_WIN32) &&                    \
--  !defined(__APPLE__) && !defined(CURL_CA_BUNDLE) && !defined(CURL_CA_PATH)
- #  define CMAKE_FIND_CAFILE
--#endif
- #include "cmStringAlgorithms.h"
- #include "cmSystemTools.h"
- 
-@@ -38,6 +35,19 @@ std::string cmCurlSetCAInfo(::CURL* curl, const std::string& cafile)
-     ::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile.c_str());
-     check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
-   }
-+
-+  /* Honor the usual environment variables.  */
-+  else if (cmSystemTools::GetEnv("SSL_CERT_FILE", e)) {
-+    ::CURLcode res =
-+      ::curl_easy_setopt(curl, CURLOPT_CAINFO, e.c_str());
-+    check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
-+  }
-+  else if (cmSystemTools::GetEnv("SSL_CERT_DIR", e)) {
-+    ::CURLcode res =
-+      ::curl_easy_setopt(curl, CURLOPT_CAPATH, e.c_str());
-+    check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
-+  }
-+
- #ifdef CMAKE_FIND_CAFILE
- #  define CMAKE_CAFILE_FEDORA "/etc/pki/tls/certs/ca-bundle.crt"
-   else if (cmSystemTools::FileExists(CMAKE_CAFILE_FEDORA, true)) {