summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-20 17:18:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-20 17:23:15 +0200
commit3d2d11973579e505c7c41ea4638dd5a7ddbb7e31 (patch)
treed73503164ed435d80444cffe6d77f006dfa89d81
parent5c4fd77097e2cecfd4780e099af7954f86779fe1 (diff)
downloadguix-3d2d11973579e505c7c41ea4638dd5a7ddbb7e31.tar.gz
gnu: Add r-fingerprint.
* gnu/packages/cran.scm (r-fingerprint): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7c25d17fbf..018adde114 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -581,6 +581,32 @@ ordered indexed observations.  It is particularly aimed at irregular time
 series of numeric vectors/matrices and factors.")
     (license license:gpl2+)))
 
+(define-public r-fingerprint
+  (package
+    (name "r-fingerprint")
+    (version "3.5.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fingerprint" version))
+       (sha256
+        (base32 "04jcwkydjrs31pia6kq8z2n9s54im950q08hs2ay15xjxxkmb8ic"))))
+    (properties `((upstream-name . "fingerprint")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=fingerprint")
+    (synopsis "Functions to Operate on Binary Fingerprint Data")
+    (description
+     "This package provides functions to manipulate binary fingerprints of
+arbitrary length.  A fingerprint is represented by an object of S4 class
+@code{fingerprint}.  The bitwise logical functions in R are overridden so that
+they can be used directly with @code{fingerprint} objects.  A number of
+distance metrics are also available.  Fingerprints can be converted to
+Euclidean vectors (i.e., points on the unit hypersphere) and can also be
+folded.  Arbitrary fingerprint formats can be handled via line handlers.
+Currently handlers are provided for CDK, MOE and BCI fingerprint data.")
+    ;; Any version of the GPL
+    (license (list license:gpl2+ license:gpl3+))))
+
 (define-public r-ggalluvial
   (package
    (name "r-ggalluvial")