summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 17:33:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 17:33:28 +0100
commit4a42ef00152064aee86d3d4b3ea0c650009f610b (patch)
treef9f19a9ed1ce081838843261ff5b5060082ff24f
parent61628e42da160d363a4311e9751331903a7ce0ef (diff)
downloadguix-4a42ef00152064aee86d3d4b3ea0c650009f610b.tar.gz
gnu: emacs-flycheck-grammalecte: Disable checks for updates.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte)[arguments]: Add
a phase to disable checks for updates.
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 584ea26e05..e544e43f47 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4810,7 +4810,15 @@ for Flow files.")
                                "/lib/python"
                                ,(version-major+minor (package-version python))
                                "/site-packages/grammalecte")))
-             #t)))))
+             #t))
+         (add-after 'unpack 'do-not-phone-home
+           ;; The package wants to check upstream Grammalecte version to
+           ;; decide if an update is in order.  Always return version
+           ;; installed so it doesn't phone home and doesn't install anything.
+           (lambda _
+             (substitute* "flycheck-grammalecte.el"
+               (("\\(flycheck-grammalecte--grammalecte-upstream-version\\)")
+                ,(format #f "\"~a\"" (package-version grammalecte)))))))))
     (inputs
      `(("grammalecte" ,grammalecte)
        ("python" ,python)))