summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-13 11:22:06 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-21 17:54:18 +0100
commit4da696877cc01077a3a159a7ef4c71ab214458e5 (patch)
treee3bcf7baa2575d974466ccf9312e0996c298891b
parent8afd19585f826e72197bc8775437f6d03ea8f813 (diff)
downloadguix-4da696877cc01077a3a159a7ef4c71ab214458e5.tar.gz
gnu: coq: Build coqide
* gnu/packages/ocaml.scm (coq): Build coqide.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 555e3fdebe..c5784db904 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -341,9 +341,11 @@ written in Objective Caml.")
     (build-system gnu-build-system)
     (native-inputs
      `(("texlive" ,texlive)
+       ("findlib" ,ocaml-findlib)
        ("hevea" ,hevea)))
     (inputs
      `(("ocaml" ,ocaml)
+       ("lablgtk" ,lablgtk)
        ("camlp5" ,camlp5)))
     (arguments
      `(#:phases
@@ -356,7 +358,8 @@ written in Objective Caml.")
                (zero? (system* "./configure"
                                "-prefix" out
                                "-mandir" mandir
-                               "-browser" browser)))))
+                               "-browser" browser
+                               "-coqide" "opt")))))
          (replace 'build
            (lambda _
              (zero? (system* "make" "-j" (number->string