summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-26 16:17:48 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:06 +0200
commit593548f063e270ad2796c181ef1e8f614067a266 (patch)
tree4922c25a7a2b22b48b3c78d5f6ae637f129d1796
parent176a501360699581b49f19ffde1ea3bb6285b8be (diff)
downloadguix-593548f063e270ad2796c181ef1e8f614067a266.tar.gz
gnu: zabbix-agentd: Enable TLS support.
* gnu/packages/monitoring.scm (zabbix-agentd)[arguments]: Pass "--with-gnutls"
in #:configure-flags.
[inputs]: Add GNUTLS.
(zabbix-server): Inherit these changes.
-rw-r--r--gnu/packages/monitoring.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 51ead2fe9b..1ff36b025b 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -188,12 +188,17 @@ etc. via a Web interface.  Features include:
             "/run/setuid-programs/fping")))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags
-       '("--enable-agent" "--enable-ipv6" "--with-libpcre2")))
+     (list #:configure-flags
+           #~(list "--enable-agent"
+                   "--enable-ipv6"
+                   "--with-libpcre2"
+                   "--with-gnutls"
+                   (string-append "--with-gnutls="
+                                  (assoc-ref %build-inputs "gnutls")))))
     (native-inputs
      (list pkg-config))
     (inputs
-     (list pcre2))
+     (list gnutls pcre2))
     (home-page "https://www.zabbix.com/")
     (synopsis "Distributed monitoring solution (client-side agent)")
     (description "This package provides a distributed monitoring
@@ -239,8 +244,6 @@ solution (client-side agent)")
                         (string-append "--with-libevent="
                                        (assoc-ref %build-inputs "libevent"))
                         "--with-net-snmp"
-                        (string-append "--with-gnutls="
-                                       (assoc-ref %build-inputs "gnutls"))
                         "--with-libcurl"
                         (string-append "--with-zlib="
                                        (assoc-ref %build-inputs "zlib")))
@@ -249,7 +252,6 @@ solution (client-side agent)")
      (modify-inputs (package-inputs zabbix-agentd)
        (prepend curl
                 libevent
-                gnutls
                 net-snmp
                 postgresql
                 zlib)))