summary refs log tree commit diff
diff options
context:
space:
mode:
authorpinoaffe <pinoaffe@airmail.cc>2022-02-06 23:32:24 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 23:32:24 +0100
commit5fcaee669e0a64496415dc85a0fff086c814d091 (patch)
tree8c5b5da678f48301268f453ffa4e9edd52de658d
parent574cc07e8ed708480a10257682f3e0fc6aba78ee (diff)
downloadguix-5fcaee669e0a64496415dc85a0fff086c814d091.tar.gz
gnu: Add emacs-ox-reveal.
* gnu/packages/emacs-xyz.scm (emacs-ox-reveal): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 26fbea3947..dc18671c46 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26511,6 +26511,33 @@ format.")
 files to numerous other formats via Pandoc.")
     (license license:gpl3+)))
 
+(define-public emacs-ox-reveal
+  (let ((commit "07900f29fada581d0e1b0f1e2057cea5e1ba8ce1")
+        (revision "0"))
+    (package
+      (name "emacs-ox-reveal")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hexmode/ox-reveal")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "132b0llxda8jivabvm2ssbrdny7q2q1c0z4ikb12k4kia3fvg6cg"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-org))
+      (home-page "https://github.com/hexmode/ox-reveal")
+      (synopsis "reveal.js Presentation Back-End for Org export engine")
+      (description
+       "Org Reveal exports your Org documents to @code{reveal.js} presentations.
+With org-reveal, you can create beautiful presentations with 3D effects from
+simple but powerful Org contents.")
+      (license license:gpl3+))))
+
 (define-public emacs-wc-mode
   (package
     (name "emacs-wc-mode")