summary refs log tree commit diff
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-04-14 19:59:42 +0000
committerAndreas Enge <andreas@enge.fr>2023-04-15 22:28:58 +0200
commit60594711e944413ac0d18687cce6828707ca8ecf (patch)
tree4b91ae929f36f84460986a0ae00e75f483bbebd8
parentdf6848565aef4371f9ac4749145a59f9a41a76f3 (diff)
downloadguix-60594711e944413ac0d18687cce6828707ca8ecf.tar.gz
gnu: python-numpy: Skip failing tests on i686.
* gnu/packages/python-xyz.scm (python-numpy): Skip failing tests on i686.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f2b801046..5dae483e56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6421,6 +6422,15 @@ include_dirs = ~:*~a/include~%"
                               ;; x86_64 CPUs such as the Core 2 Duo (see:
                               ;; https://github.com/numpy/numpy/issues/22170).
                               "and not test_rint_big_int "
+                              ;; The huge_array test is too large for 32-bit (see:
+                              ;; https://bugs.gentoo.org/843599 and
+                              ;; https://bugs.gentoo.org/846548).
+                              ;; TestKind.test_all is a Fortran type failure
+                              ;; that may be toolchain or environment related.
+                              #$@(if (or (target-x86?) (target-arm32?))
+                                     `(" and not test_identityless_reduction_huge_array"
+                                       " and not (TestKind and test_all)")
+                                   '())
                               ;; These tests seem to fail on machines without
                               ;; an FPU is still under investigation upstream.
                               ;; https://github.com/numpy/numpy/issues/20635