summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-08 01:18:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-08 01:18:08 -0400
commit697e7d632418ba024c505a5a60d1273e4732a389 (patch)
tree6a1ec425febb8fc1d014a1e8ed1c5eebbcd78ecb
parentc0833f3b0ce2ecaaa33b88be7a7ebc29df3ffe58 (diff)
downloadguix-697e7d632418ba024c505a5a60d1273e4732a389.tar.gz
gnu: python-pyzmq: Enable the draft test.
* gnu/packages/python-xyz.scm (python-pyzmq) [arguments]: Delete the
disable-problematic-tests phase and add a configure phase.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a89f25b5b6..f196d7a816 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11973,11 +11973,11 @@ applications.")
        (list (string-append "--zmq=" (assoc-ref %build-inputs "zeromq")))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'disable-problematic-tests
+         (add-before 'build 'configure
            (lambda _
-             ;; FIXME: The test_draft.TestDraftSockets test fails with:
-             ;;   zmq.error.Again: Resource temporarily unavailable
-             (delete-file "zmq/tests/test_draft.py")))
+             ;; Our zeromq package is built with '--enable-drafts'; also
+             ;; enable draft support for pyzmq so the draft test passes.
+             (setenv "ZMQ_DRAFT_API" "1")))
          (add-before 'check 'build-extensions
            (lambda _
              ;; Cython extensions have to be built before running the tests.