summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 22:08:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:39:01 +0200
commit84de0e317511515d310ca54d90bbd7996babe0fc (patch)
tree20489e25d9fa787f4bc8d7d2fa30d089e05493ef
parentead37cb68557f40823fed8f932ddf051261e2438 (diff)
downloadguix-84de0e317511515d310ca54d90bbd7996babe0fc.tar.gz
gnu: python-pygithub: Update to 1.55.
* gnu/packages/python-xyz.scm (python-pygithub): Update to 1.55.
  [propagated-inputs]: Add python-pynacl.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c430b99600..1822eeea36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4589,7 +4589,7 @@ to deprecate classes, functions or methods.")
 (define-public python-pygithub
   (package
     (name "python-pygithub")
-    (version "1.54.1")
+    (version "1.55")
     (source
      ;; We fetch from the Git repo because there are no tests in the PyPI
      ;; archive.
@@ -4600,7 +4600,7 @@ to deprecate classes, functions or methods.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1nl74bp5ikdnrc8xq0qr25ryl1mvarf0xi43k8w5jzlrllhq0nkq"))))
+        (base32 "082bxffpy4h97dsay3l75cpgfjj10kywkvicnm6xscwvah285q9y"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4612,7 +4612,7 @@ to deprecate classes, functions or methods.")
              #t)))))
     (propagated-inputs
      (list python-cryptography python-deprecated python-pyjwt
-           python-requests))
+           python-pynacl python-requests))
     (native-inputs
      (list python-httpretty python-pytest))
     (home-page "https://pygithub.readthedocs.io/en/latest/")