summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-24 00:17:28 +0200
committerMarius Bakke <marius@gnu.org>2020-06-24 01:04:15 +0200
commit862d6a9173bf57ffcb3698104b33cd7d1085a12b (patch)
tree31f94f8a5eb9f82b6fb4133327dde1adef6edade
parentac944584859a77c84eaff3240416b97d230db1ff (diff)
downloadguix-862d6a9173bf57ffcb3698104b33cd7d1085a12b.tar.gz
gnu: python-on-guile: Wrap with own Guile modules.
* gnu/packages/guile-xyz.scm (python-on-guile)[arguments]: Add the output
modules to the wrapper.
-rw-r--r--gnu/packages/guile-xyz.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 19b5284d5b..e7f4848bf4 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2602,13 +2602,28 @@ serializing continuations or delimited continuations.")
          (add-after 'install 'wrap
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Wrap the 'python' executable so it can find its
-             ;; dependencies.
-             (let ((out  (assoc-ref outputs "out")))
+             ;; dependencies and own modules.
+             (let* ((out (assoc-ref outputs "out"))
+                    (guile-version ,(version-major+minor
+                                     (package-version guile-3.0)))
+                    (scm (string-append out "/share/guile/site/"
+                                        guile-version))
+                    (ccache (string-append out "/lib/guile/" guile-version
+                                           "/site-ccache"))
+                    (load-path (string-join
+                                (cons scm
+                                      ;; XXX: cdr because we augment it above.
+                                      (cdr (string-split
+                                            (getenv "GUILE_LOAD_PATH") #\:)))
+                                ":"))
+                    (compiled-path (string-append
+                                    ccache ":"
+                                    (getenv "GUILE_LOAD_COMPILED_PATH"))))
                (wrap-program (string-append out "/bin/python")
                  `("GUILE_LOAD_PATH" ":" prefix
-                   (,(getenv "GUILE_LOAD_PATH")))
+                   (,load-path))
                  `("GUILE_LOAD_COMPILED_PATH" ":" prefix
-                   (,(getenv "GUILE_LOAD_COMPILED_PATH"))))
+                   (,compiled-path)))
                #t))))))
     (inputs
      `(("guile" ,guile-3.0)))