summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-30 20:08:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 20:57:21 +0100
commit8f22bf9e6d4985fed9ff3b4e09d53ae1b95e1568 (patch)
tree103222d66d043b1849a37f80472dc8e7e8bc7221
parent0a3849f6102b7d42159065363d3331819e84ec80 (diff)
downloadguix-8f22bf9e6d4985fed9ff3b4e09d53ae1b95e1568.tar.gz
gnu: json-modern-cxx: Fetch from git.
* gnu/packages/cpp.scm (json-modern-cxx)[source]: Use GIT-FETCH.
[source](snippet): End on #t.
-rw-r--r--gnu/packages/cpp.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f5aa447a79..4e8f12248f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -203,15 +203,16 @@ as ordering relation.")
   (package
     (name "json-modern-cxx")
     (version "3.1.2")
+    (home-page "https://github.com/nlohmann/json")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/nlohmann/json/archive/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference (url home-page)
+                           (commit (string-append "v" version))))
        (sha256
         (base32
-         "0m5fhdpx2qll933db2nsi30nns3cifavzvijzz6mxhdkpmngmzz8"))
-       (file-name (string-append name "-" version ".tar.gz"))
+         "1mpr781fb2dfbyscrr7nil75lkxsazg4wkm749168lcf2ksrrbfi"))
+       (file-name (git-file-name name version))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -227,13 +228,13 @@ as ordering relation.")
                (substitute* files
                  (("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
                   (string-append
-                   "#include <fifo_map/" fifo-map-hpp ">")))))))))
+                   "#include <fifo_map/" fifo-map-hpp ">")))))
+           #t))))
     (native-inputs
      `(("amalgamate" ,amalgamate)))
     (inputs
      `(("catch2" ,catch-framework2)
        ("fifo-map" ,fifo-map)))
-    (home-page "https://github.com/nlohmann/json")
     (build-system cmake-build-system)
     (synopsis "JSON parser and printer library for C++")
     (description "JSON for Modern C++ is a C++ JSON library that provides