summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-24 16:06:23 +0000
committerAlex Kost <alezost@gmail.com>2017-09-28 18:43:23 +0300
commit8fc559dcc5125c6d71544ea34b6c67edb4ed744e (patch)
tree78fe8bcb4a693938929439384e62f69904eaa27c
parent69b498a162e9c1fca459bf0737343619e6c7de96 (diff)
downloadguix-8fc559dcc5125c6d71544ea34b6c67edb4ed744e.tar.gz
gnu: Add emacs-jinja2-mode.
* gnu/packages/emacs.scm (emacs-jinja2-mode): New variable.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ebe099c689..ac31891381 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2569,6 +2569,27 @@ insertion mode.  When enabled all keys are implicitly prefixed with
 @samp{C-} (among other helpful shortcuts).")
       (license license:gpl3+))))
 
+(define-public emacs-jinja2-mode
+  (package
+    (name "emacs-jinja2-mode")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/paradoxxxzero/jinja2-mode/"
+                           "archive/v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0cgxjab1kla2zc2fj7bzib6i7snp08zshandmp9kqcm85l262xpn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/paradoxxxzero/jinja2-mode")
+    (synopsis "Major mode for jinja2")
+    (description
+     "Emacs major mode for jinja2 with: syntax highlighting,
+sgml/html integration, and indentation (working with sgml).")
+    (license license:gpl3+)))
+
 (define-public emacs-rfcview
   (package
     (name "emacs-rfcview")