summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-20 11:32:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-20 11:32:08 +0300
commit92330ba90d782b3b215b4521d93f5869a70e51e0 (patch)
tree8f89d78c67cbdf9b25ef143d9a0055b802096e39
parent846b2534df0138a72fe8ee6a541f97de59697cb0 (diff)
downloadguix-92330ba90d782b3b215b4521d93f5869a70e51e0.tar.gz
gnu: efl: Remove hardcoding pulseaudio and libsndfile.
* gnu/packages/enlightenment.scm (efl)[arguments]: Remove custom phase
to hardlink to the locations of pulseaudio and libsndfile.
-rw-r--r--gnu/packages/enlightenment.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index a1df1367a5..e8bd387ef3 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -131,23 +131,7 @@
                            "--enable-multisense"
                            "--with-opengl=es"
                            "--enable-egl"
-                           "--enable-harfbuzz")
-       #:phases
-       (modify-phases %standard-phases
-         ;; ecore_audio cannot find pulseaudio or libsndfile when compiled.
-         ;; Starting in version 1.18.0, these two libraries are dlopened so
-         ;; we hardcode their locations as a temporary workaround.
-         (add-after 'configure 'hardlink-dlopen-files
-           (lambda _
-             (substitute* "src/lib/ecore_audio/ecore_audio.c"
-                          (("libpulse.so.0")
-                           (string-append (assoc-ref %build-inputs "pulseaudio")
-                                          "/lib/libpulse.so.0")))
-             (substitute* "src/lib/ecore_audio/ecore_audio.c"
-                          (("libsndfile.so.1")
-                           (string-append (assoc-ref %build-inputs "libsndfile")
-                                          "/lib/libsndfile.so.1")))
-             #t)))))
+                           "--enable-harfbuzz")))
     (home-page "https://www.enlightenment.org")
     (synopsis "Enlightenment Foundation Libraries")
     (description