summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 22:24:31 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:58 -0500
commit9b1315a4adc9cbea6af7b0bfe045032af8aa81c4 (patch)
tree3129fadf62fbf889e30f9447d91dbf41d8bf4aeb
parent226b2af51a4fa936ccb4f6d35505f893808b7b31 (diff)
downloadguix-9b1315a4adc9cbea6af7b0bfe045032af8aa81c4.tar.gz
gnu: python-oslo: Update to 3.1.1.
* gnu/packages/openstack.scm (python-oslo): Update to 3.1.1.
[phases]: Add new 'relax-requirements phase.
[propagated-inputs]:  Move python-pbr...
[native-inputs]: ...here.  Add python-bandit, python-coverage and python-stestr.
-rw-r--r--gnu/packages/openstack.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 5fa5a7928c..4ed2948290 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -433,22 +433,33 @@ common features used in Tempest.")
 (define-public python-oslo.context
   (package
     (name "python-oslo.context")
-    (version "2.20.0")
+    (version "3.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "oslo.context" version))
        (sha256
         (base32
-         "0iiq9rpwg6wrdqnhf3d8z8g0g7fjhs5zn6qw6igvxplz2c3rbvvx"))))
+         "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'relax-requirements
+                    (lambda _
+                      (substitute* "test-requirements.txt"
+                        (("hacking>=3.0.1,<3.1.0")
+                         "hacking>=3.0.1"))
+                      #t)))))
     (propagated-inputs
-     `(("python-debtcollector" ,python-debtcollector)
-       ("python-pbr" ,python-pbr)))
+     `(("python-debtcollector" ,python-debtcollector)))
     (native-inputs
-     `(("python-fixtures" ,python-fixtures)
+     `(("python-bandit" ,python-bandit)
+       ("python-coverage" ,python-coverage)
+       ("python-fixtures" ,python-fixtures)
        ("python-hacking" ,python-hacking)
-       ("python-oslotest" ,python-oslotest)))
+       ("python-oslotest" ,python-oslotest)
+       ("python-pbr" ,python-pbr)
+       ("python-stestr" ,python-stestr)))
     (home-page "https://launchpad.net/oslo")
     (synopsis "Oslo context library")
     (description