summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:09 +0200
commita0c361cb3f7d7111476b1210c3e5d91eb8555d70 (patch)
treedf8e9444a83259967d16dcc9d508e3f92097c65f
parent88e3a3529f6ffae9a73ff6bb8c7e5459b47cd8f8 (diff)
downloadguix-a0c361cb3f7d7111476b1210c3e5d91eb8555d70.tar.gz
gnu: linsmith: Fix input types.
* gnu/packages/engineering.scm (linsmith)[native-inputs]:
Remove input labels.  Move gtk+-2 and libgnomeui from here…
[inputs]: …to here.
-rw-r--r--gnu/packages/engineering.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 41cd89e057..070a372b5a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1302,9 +1302,9 @@ with the kernel and various utilities such as per-cpu counters.")
     (arguments
      '(#:configure-flags '("CFLAGS=-fcommon")))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("gtk" ,gtk+-2)
-       ("libgnome" ,libgnomeui)))
+     (list pkg-config))
+    (inputs
+     (list gtk+-2 libgnomeui))
     (home-page "https://jcoppens.com/soft/linsmith/index.en.php")
     (synopsis "Smith Charting program")
     (description "LinSmith is a Smith Charting program, mainly designed for