summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-20 00:50:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-20 02:04:50 +0100
commita86a6fb6fcae3fc0e530149a0106ff7a7c4b3679 (patch)
tree8948c0e4a37d460478c32149199cf89810f50577
parent83197fdf0554deae2110e10263a25366e33113cd (diff)
downloadguix-a86a6fb6fcae3fc0e530149a0106ff7a7c4b3679.tar.gz
gnu: bcachefs-tools-static: Fix build.
* gnu/packages/crypto.scm (keyutils)[arguments]: Do build the static
library, but move it to the :static output in a new 'install:static
phase.
* gnu/packages/file-systems.scm (bcachefs-tools/static)[inputs]:
Add this keyutils:static.
-rw-r--r--gnu/packages/crypto.scm16
-rw-r--r--gnu/packages/file-systems.scm1
2 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 85729471f5..80a4315aa7 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -385,16 +385,26 @@ the wrong hands.")
     (arguments
      (list #:make-flags
            #~(list (string-append "CC=" #$(cc-for-target))
+                   ;; "NO_ARLIB=1" would cleanly disable static libraries.
                    "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
                    (string-append "DESTDIR=" #$output)
                    "INCLUDEDIR=/include"
                    "LIBDIR=/lib"
                    "MANDIR=/share/man"
-                   "SHAREDIR=/share/keyutils"
-                   "NO_ARLIB=1")        ; omit static libraries
+                   "SHAREDIR=/share/keyutils")
            #:phases
            #~(modify-phases %standard-phases
-               (delete 'configure))     ; no configure script
+               (delete 'configure)      ; no configure script
+               (add-after 'install 'install:static
+                 (lambda _
+                   (with-directory-excursion #$output
+                     (for-each (lambda (file)
+                                 (let ((target (string-append #$output:static
+                                                              "/" file)))
+                                   (format #t "~a -> ~a\n" file target)
+                                   (mkdir-p (dirname target))
+                                   (rename-file file target)))
+                               (find-files "lib" "\\.a$"))))))
            #:test-target "test"))
     (inputs
      (list mit-krb5))
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 20599d37fe..8c0fff00b7 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -507,6 +507,7 @@ performance and other characteristics.")
                   ((".*\\$\\(INSTALL\\).* lib.*") ""))))))))
      (inputs
       `(("eudev:static" ,eudev "static")
+        ("keyutils:static" ,keyutils "static")
         ("libscrypt:static" ,libscrypt "static")
         ("lz4:static" ,lz4 "static")
         ("util-linux:static" ,util-linux "static") ; lib{blkid,uuid}