summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2022-02-07 13:05:42 +1100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-19 01:08:07 +0100
commitb731d34ed796ad3ca1cfba6e08369ffd6dcb57bf (patch)
tree0052c209651a436e7ca0c1558a3b29937304d515
parent81359197b43b3717b4c99dc9d3ea3d70db009782 (diff)
downloadguix-b731d34ed796ad3ca1cfba6e08369ffd6dcb57bf.tar.gz
gnu: Remove python-dukpy, python2-dukpy.
* gnu/packages/python-xyz.scm: Remove unused packages python-dukpy,
python2-dukpy.
This is actually not the 'dukpy' package in pypi either but something
else made for calibre.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 13e2bd7e1f..8424065a1d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20547,32 +20547,6 @@ executed more than a given number of times during a given period.")
 (define-public python2-ratelimiter
   (package-with-python2 python-ratelimiter))
 
-(define-public python-dukpy
-  (package
-    (name "python-dukpy")
-    (version "0.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/kovidgoyal/dukpy")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "13h21nqzasv4zj32xs61brmc106pr2cx243672crcmwxxnjgaxls"))))
-    (build-system python-build-system)
-    (home-page "https://github.com/kovidgoyal/dukpy")
-    (synopsis "Run JavaScript in python")
-    (description
-     "dukpy is a JavaScript runtime environment for Python using the duktape
-embeddable JavaScript engine.")
-    ;; Dukpy is licensed under MIT like the embedded duktape library,
-    ;; with 'errors.c' as GPL3.
-    (license (list license:expat license:gpl3))))
-
-(define-public python2-dukpy
-  (package-with-python2 python-dukpy))
-
 (define-public python-jsonrpclib-pelix
   (package
     (name "python-jsonrpclib-pelix")