summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-04 17:10:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-04 17:11:49 +0100
commitb9c5dff57ff961a16c8fc24843a4535ea817e732 (patch)
tree93255f77ba691fd3b05fc5401938133e377ac64e
parent48c2983d95a0f889b3dd5adddb143d080b05383e (diff)
downloadguix-b9c5dff57ff961a16c8fc24843a4535ea817e732.tar.gz
gnu: Add r-varhandle.
* gnu/packages/cran.scm (r-varhandle): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b9b1171496..448ac5b724 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
@@ -31600,6 +31600,27 @@ data.  This package provides functions that query the BIEN database by
 constructing and executing optimized SQL queries.")
     (license license:expat)))
 
+(define-public r-varhandle
+  (package
+    (name "r-varhandle")
+    (version "2.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "varhandle" version))
+       (sha256
+        (base32 "1l42d0s6fbjjc9l28a2m3myxkrx2c0p0b9yj8wjjjgilw19yc3lv"))))
+    (properties `((upstream-name . "varhandle")))
+    (build-system r-build-system)
+    (home-page "https://bitbucket.org/mehrad_mahmoudian/varhandle")
+    (synopsis "Functions for robust variable handling")
+    (description
+     "This package contains some functions to help users (especially data
+explorers) to make more sense of their variables and take the most out of
+variables and hardware resources.  Functions in this package are supposed to
+be efficient and easy to use.")
+    (license license:gpl2+)))
+
 (define-public r-ggh4x
   (package
     (name "r-ggh4x")