summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-16 20:56:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 15:16:55 +0200
commitbc0e5133ae61b34439355d47119dcc9ff3332937 (patch)
treed208f2ac1526ada3808146c99bc156e31a8b073c
parentcb6d4aff4454e65a039642f44204e7c892dc9d56 (diff)
downloadguix-bc0e5133ae61b34439355d47119dcc9ff3332937.tar.gz
gnu: multipath-tools: Enable tests.
* gnu/packages/linux.scm (multipath-tools)[arguments]: Remove #:tests?.  Add
 #:test-target.  Add phase to add missing linker flag.
[native-inputs]: Add CMOCKA.
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2d8acea0e3..aa52068794 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4205,7 +4205,7 @@ arrays when needed.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                      ; no tests
+     '(#:test-target "test"
        #:parallel-build? #f             ;XXX: broken in 0.8.4
        #:make-flags (list "CC=gcc"
                           (string-append "DESTDIR="
@@ -4242,11 +4242,22 @@ arrays when needed.")
                (("bool is_queueing;")
                 "bool is_queueing = false;"))
              #t))
+         (add-after 'unpack 'fix-linking-tests
+           (lambda _
+             ;; Add missing linker flag for -lmpathcmd.  This should be fixed
+             ;; for versions > 0.8.4.
+             (substitute* "tests/Makefile"
+               (("-lmultipath -lcmocka")
+                "-lmultipath -L$(mpathcmddir) -lmpathcmd -lcmocka"))
+             #t))
          (delete 'configure))))         ; no configure script
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("valgrind" ,valgrind)))
+       ("valgrind" ,valgrind)
+
+       ;; For tests.
+       ("cmocka" ,cmocka)))
     (inputs
      `(("json-c" ,json-c)
        ("libaio" ,libaio)