summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 15:47:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 14:37:03 +0100
commitbc47a1bf02e9071743d56243ba5aabf4b764afc5 (patch)
treeb8e6863d7c8443ff977deae4005a83ba39d27e36
parent49ec1fbc8f0872241bfff1827bd9b47455b0980c (diff)
downloadguix-bc47a1bf02e9071743d56243ba5aabf4b764afc5.tar.gz
gnu: Add python-pygtrie.
* gnu/packages/python-xyz.scm (python-pygtrie): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d429a4a734..4298fd4c40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4978,6 +4978,23 @@ text styles of documentation.")
     (description "This package installs Github custom lexers to Pygments.")
     (license license:bsd-3)))
 
+(define-public python-pygtrie
+  (package
+    (name "python-pygtrie")
+    (version "2.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pygtrie" version))
+              (sha256
+               (base32
+                "1qm4xdmzd4q5pc9h5gjdpr5m7lg06k8dvqnjn7d07d3fhani8d90"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/mina86/pygtrie")
+    (synopsis "Pure Python trie data structure implementation")
+    (description
+     "This package provides a pure Python trie data structure implementation.")
+    (license license:asl2.0)))
+
 (define-public python-bump2version
   (package
     (name "python-bump2version")