summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 20:24:34 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:38:57 +0200
commitc037745a4c99a5fc9483f6e0e12e2867d26cf10c (patch)
tree11cdabba29d80551c0bf8cf3a44d74d9cbd51213
parent0b929d2d239a5e32f2c87e6744105dff34c72c4a (diff)
downloadguix-c037745a4c99a5fc9483f6e0e12e2867d26cf10c.tar.gz
gnu: Add python-requestsexceptions.
* gnu/packages/openstack.scm (python-requestsexceptions): New variable.
-rw-r--r--gnu/packages/openstack.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4e3e933509..217fcb4a93 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -924,3 +924,27 @@ permanence.")
      "Git-review is a command-line tool that helps submitting Git branches to
 Gerrit for review, or fetching existing ones.")
     (license asl2.0)))
+
+(define-public python-requestsexceptions
+  (package
+    (name "python-requestsexceptions")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "requestsexceptions" version))
+              (sha256
+               (base32
+                "0r9hp9yzgj8r81q5gc6r8sgxldqc09xi6ax0b7a6dw0qfv3wp5dh"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f))  ; no tests
+    (native-inputs (list python-pbr))
+    (home-page "https://www.openstack.org/")
+    (synopsis "Import exceptions from potentially bundled packages in requests")
+    (description "The Python requests library bundles the urllib3 library,
+however, some software distributions modify requests to remove the bundled
+library.  This makes some operations difficult, such as suppressing the
+“insecure platform warning” messages that urllib emits.  This package is a
+simple library to find the correct path to exceptions in the requests library
+regardless of whether they are bundled or not.")
+    (license asl2.0)))