summary refs log tree commit diff
diff options
context:
space:
mode:
authorEidvilas Markevičius <markeviciuseidvilas@gmail.com>2023-07-06 12:10:01 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-08 00:44:07 -0400
commitc0833f3b0ce2ecaaa33b88be7a7ebc29df3ffe58 (patch)
treed10728e506ab5f3cdf084e702d77cff5d0a2eeaa
parent77b5b1db8321412b90b948421dbe2b920ff22445 (diff)
downloadguix-c0833f3b0ce2ecaaa33b88be7a7ebc29df3ffe58.tar.gz
gnu: Add gnome-shell-extension-vitals.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vitals): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/gnome-xyz.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4ce102d8ed..0507fc749b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -19,6 +19,7 @@
 ;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2022 Sughosha <sughosha@proton.me>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1328,6 +1329,61 @@ Speakers etc. of the same device are also displayed for selection.")
 of windows.")
       (license license:expat))))
 
+(define-public gnome-shell-extension-vitals
+  (package
+    (name "gnome-shell-extension-vitals")
+    (version "62.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/corecoding/Vitals")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wmw5yd38vyv13x6frbafp21bdhlyjd5ggimdf2696irfhnm828h"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          (delete-file "schemas/gschemas.compiled")
+                          (for-each delete-file
+                                    (find-files "locale" "\\.mo$"))))))
+    (build-system copy-build-system)
+    (native-inputs (list `(,glib "bin") gettext-minimal))
+    (inputs (list libgtop))
+    (arguments
+     (list #:modules '((guix build copy-build-system)
+                       (guix build utils)
+                       (ice-9 string-fun))
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'install 'compile-schemas
+                          (lambda _
+                            (invoke "glib-compile-schemas" "--strict"
+                                    "schemas")))
+                        (add-before 'install 'compile-locales
+                          (lambda _
+                            (for-each (lambda (file)
+                                        (let ((destfile (string-replace-substring
+                                                         file ".po" ".mo")))
+                                          (invoke "msgfmt" "-c" file "-o"
+                                                  destfile)))
+                                      (find-files "locale" "\\.po$")))))
+           #:install-plan #~'(("."
+                               "share/gnome-shell/extensions/Vitals@CoreCoding.com"
+                               #:include-regexp ("\\.js(on)?$" "\\.css$"
+                                                 "\\.ui$"
+                                                 "\\.svg$"
+                                                 "\\.xml$"
+                                                 "\\.mo$"
+                                                 "\\.compiled$")))))
+    (home-page "https://github.com/corecoding/Vitals")
+    (synopsis
+     "GNOME Shell extension displaying computer resource/sensor stats")
+    (description
+     "Vitals is a GNOME Shell extension that can display the computer
+temperature, voltage, fan speed, memory usage and CPU load from the top menu
+bar of the GNOME Shell.")
+    (license license:gpl2+)))
+
 (define-public arc-theme
   (package
     (name "arc-theme")