summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-06-30 11:19:15 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-07-01 09:01:20 +1000
commitc7f04517a6795933c2adafa037fe6c79c90d4cc4 (patch)
tree40b2e6c2eb70628a91f892cc9d918ffbfad2b399
parent84d08af653987f43987a5113e31b8704e24a47f2 (diff)
downloadguix-c7f04517a6795933c2adafa037fe6c79c90d4cc4.tar.gz
gnu: Add r-glmnet.
* gnu/packages/statistics.scm (r-glmnet): New variable.
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f0373920e9..73c30ae080 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2244,6 +2244,32 @@ singular and eigenvalue decompositions, as well as for principal component
 analysis of large sparse or dense matrices.")
     (license (list license:gpl2+ license:gpl3+))))
 
+(define-public r-glmnet
+  (package
+   (name "r-glmnet")
+   (version "2.0-5")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "glmnet" version))
+     (sha256
+      (base32
+       "1cbpzmbv837fvq88rgn6mgzgr9f1wqp9fg8gh2kkmngvr1957a9c"))))
+   (build-system r-build-system)
+    (inputs
+     `(("gfortran" ,gfortran)))
+   (propagated-inputs
+    `(("r-foreach" ,r-foreach)))
+   (home-page "http://www.jstatsoft.org/v33/i01")
+   (synopsis "Lasso and elastic-net regularized generalized linear models")
+   (description
+    "The glmnet package provides efficient procedures for fitting the entire
+lasso or elastic-net regularization path for linear and Poisson regression, as
+well as logistic, multinomial, Cox, multiple-response Gaussian and grouped
+multinomial models.  The algorithm uses cyclical coordinate descent in a
+path-wise fashion.")
+   (license license:gpl2+)))
+
 (define-public r-pkgmaker
   (package
     (name "r-pkgmaker")