summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:10 +0200
commitc8c78b08d228fd44df9b5df78452ee69d7407dd8 (patch)
tree79cb634187e102333ca86772d838c96effe78c23
parent479eb63f2a68cfac1866aefe245186a0bb3ef083 (diff)
downloadguix-c8c78b08d228fd44df9b5df78452ee69d7407dd8.tar.gz
gnu: pcb-rnd: Prepare for cross-compilation.
* gnu/packages/engineering.scm (pcb-rnd)[arguments]: Use CC-FOR-TARGET.
-rw-r--r--gnu/packages/engineering.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f31d4bd04d..4499d9e07c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -541,7 +541,7 @@ optimizer; and it can produce photorealistic and design review images.")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'cc-is-gcc
-            (lambda _ (setenv "CC" "gcc")))
+            (lambda _ (setenv "CC" #$(cc-for-target))))
           (replace 'configure
             ;; The configure script doesn't tolerate most of our configure flags.
             (lambda _