summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-03-03 13:25:53 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-08-16 21:37:32 +0300
commitd0b13d7b9b34e79a6ab7c5b5d06455488c822203 (patch)
treeda12e40f6907b033132fa42a97d40d18dd58f9cf
parentab1bd285db9c106076e1c37b63460e001a3cf579 (diff)
downloadguix-d0b13d7b9b34e79a6ab7c5b5d06455488c822203.tar.gz
gnu: fossil: Update to 2.2.
* gnu/packages/version-control.scm (fossil): Update to 2.2.
[source]: Add uri for older versions.
[arguments]: Enable previously disabled test.
-rw-r--r--gnu/packages/version-control.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 869672ca45..36a6b7cd18 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1337,16 +1337,21 @@ repository\" with git-annex.")
 (define-public fossil
   (package
     (name "fossil")
-    (version "1.35")
+    (version "2.2")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://www.fossil-scm.org/index.html/uv/download/"
-             "fossil-src-" version ".tar.gz"))
+       ;; Older downloads are moved to another URL.
+       (uri (list
+             (string-append
+              "https://www.fossil-scm.org/index.html/uv/download/"
+              "fossil-src-" version ".tar.gz")
+             (string-append
+              "https://www.fossil-scm.org/index.html/uv/"
+              "fossil-src-" version ".tar.gz")))
        (sha256
         (base32
-         "07ds6rhq69bhydpm9a01mgdhxf88p9b6y5hdnhn8gjc7ba92zyf1"))))
+         "0wfgacfg29dkl0c3l1rp5ji0kraa64gcbg5lh8p4m7mqdqcq53wv"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("tcl" ,tcl)                     ;for configuration only
@@ -1375,9 +1380,6 @@ repository\" with git-annex.")
                     (lambda _
                       (setenv "USER" "guix")
                       (setenv "TZ" "UTC")
-                      ;; Fixing the th1 test would require many backports, so
-                      ;; just disable for now.
-                      (delete-file "test/th1.test")
                       #t)))))
     (home-page "https://fossil-scm.org")
     (synopsis "Software configuration management system")