summary refs log tree commit diff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2023-01-21 19:09:25 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-25 18:53:47 +0100
commitd8d37b98e962cf2591d63b344834b1a037779165 (patch)
treeb899d25e5fa08a08b93c24206578020f66bb639f
parent035c10dd479f48bc2613e08a997ed1da3926ccc2 (diff)
downloadguix-d8d37b98e962cf2591d63b344834b1a037779165.tar.gz
gnu: Add emacs-helm-themes.
* gnu/packages/emacs-xyz.scm (emacs-helm-themes): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c6427ffad..68c8d84847 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31180,6 +31180,31 @@ language they are written in.")
 fish-completion.  It can be used in both Eshell and M-x shell.")
     (license license:gpl3+)))
 
+(define-public emacs-helm-themes
+  (let ((version "0.05")
+        (commit "92ee3ad4edf1d068feb0822a05638db99b50a7c0")
+        (revision "1"))
+    (package
+      (name "emacs-helm-themes")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/helm-themes")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1p62gg8nnb6kmb9mk66230p0ap0zwwzhzdxr3j34z5ls574vr6s7"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-helm))
+      (home-page "https://github.com/emacsorphanage/helm-themes")
+      (synopsis "Emacs theme selection with Helm interface")
+      (description
+       "Helm Themes provide an Emacs theme selection with Helm interface.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-switch-to-repl
   (package
     (name "emacs-helm-switch-to-repl")