summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-18 23:54:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:47 -0400
commitde20b74fc2debed186edbd613c7afe6a992c02b2 (patch)
tree90260c67b41b58c5f6277801abe58e4dae0592ca
parentf1e126c03b25a9d20c3543d082b1f5a7d756e0f6 (diff)
downloadguix-de20b74fc2debed186edbd613c7afe6a992c02b2.tar.gz
gnu: Add qt5compat.
* gnu/packages/qt.scm (qt5compat): New variable.
-rw-r--r--gnu/packages/qt.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ce5df74f7d..488cfa6120 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -831,6 +831,35 @@ developers using C++ or QML, a CSS & JavaScript like language.")
             (variable "XDG_CONFIG_DIRS")
             (files '("etc/xdg")))))))
 
+(define-public qt5compat
+  (package
+    (name "qt5compat")
+    (version "6.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (qt5-urls name version))
+              (sha256
+               (base32
+                "1zbcaswpl79ixcxzj85qzjq73962s4c7316pibwfrskqswmwcgm4"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'install 'delete-installed-tests
+                     (lambda _
+                       (delete-file-recursively
+                        (string-append #$output "/tests")))))))
+    (native-inputs (list perl))
+    (inputs (list icu4c libxkbcommon qtbase qtdeclarative qtshadertools))
+    (home-page (package-home-page qtbase))
+    (synopsis "Legacy Qt 5 APIs ported to Qt 6")
+    (description "The @code{qt5compat} package includes application
+programming interfaces (APIs) from Qt 5 that were ported to Qt 6, to ease
+migration.  It provides for example the @code{GraphicalEffects} module that
+came with the @{qtgraphicaleffects} Qt 5 package.")
+    (license (list license:gpl2+ license:lgpl3+)))) ;dual licensed
+
 (define-public qtsvg-5
   (package
     (inherit qtbase-5)