summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-01-20 15:10:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-20 17:18:59 +0100
commite5f7b2c431fb618ce54927400a37721cfbd17de7 (patch)
tree98dfadf76447e8399c935a1f4f67798a3f8356d6
parent8eb2a6c9b8c2f204b3ebd15f2990e6694b9e014b (diff)
downloadguix-e5f7b2c431fb618ce54927400a37721cfbd17de7.tar.gz
gnu: Add r-scattermore.
* gnu/packages/cran.scm (r-scattermore): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 64c7f08096..ae86421192 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25161,6 +25161,29 @@ alignment using warping functions, handling of replicated measurements as well
 as allowing spectra with different resolutions.")
     (license license:gpl3+)))
 
+(define-public r-scattermore
+  (package
+    (name "r-scattermore")
+    (version "0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "scattermore" version))
+       (sha256
+        (base32
+         "18nzlprmphkvjg946h10h2qq0wbkmv2526p8di6k2xl4gccq0qpk"))))
+    (properties `((upstream-name . "scattermore")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-scales" ,r-scales)))
+    (home-page "https://github.com/exaexa/scattermore")
+    (synopsis "Scatterplots with more points")
+    (description
+     "This package provides C-based tools for converting large scatterplot
+data to rasters.  It speeds up plotting of data with millions of points.")
+    (license license:gpl3+)))
+
 (define-public r-seurat
   (package
     (name "r-seurat")