summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:21:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:24 +0300
commitf16cf693e9ddcf775667c1616eb54b17a600c416 (patch)
tree976683835f40f4512ad30caf0f5d5d3983f16c58
parentb1cad99e83db6b34ba63d28f7865dda325c19d2a (diff)
downloadguix-f16cf693e9ddcf775667c1616eb54b17a600c416.tar.gz
gnu: Add julia-libpng-jll.
* gnu/packages/julia-xyz.scm (julia-libpng-jll): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8fc9d359c6..624576b038 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -965,6 +965,44 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
 and printing JSON documents.")
     (license license:expat)))
 
+(define-public julia-libpng-jll
+  (package
+    (name "julia-libpng-jll")
+    (version "1.6.37+5")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/LibPNG_jll.jl")
+               (commit (string-append "libpng-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "10azxv26j8r193dg9i9x7ajm3frhwbhj8zzi40fj59fxm81xz6dx"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"libpng\"")
+                    (string-append "\"" (assoc-ref inputs "libpng") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libpng" ,libpng)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-zlib-jll" ,julia-zlib-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/LibPNG_jll.jl")
+    (synopsis "Libpng library wrappers")
+    (description "This package provides a wrapper for the libpng library.")
+    (license license:expat)))
+
 (define-public julia-macrotools
   (package
     (name "julia-macrotools")