summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-16 11:03:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-16 11:12:01 +0100
commitfcf8c6c5652cac87647d87e87dede3a7b154716b (patch)
treeb17f6d34b46cf8a95fec0bda9e993dc9fc2c221d
parent097cf21d1d34f4f66a403c3fb6e15b6709c4dd8a (diff)
downloadguix-fcf8c6c5652cac87647d87e87dede3a7b154716b.tar.gz
gnu: hisat2: Update to 2.2.1.
* gnu/packages/bioinformatics.scm (hisat2): Update to 2.2.1.
[source]: Fetch from git repository on Github.
[arguments]: Add phase to build manual; remove trailing #t from other phases.
[native-inputs]: Remove unzip.
[home-page]: Update.
[inputs]: Add python-wrapper.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d9afe2c56f..90e81354a5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3819,15 +3819,17 @@ particular, reads spanning multiple exons.")
 (define-public hisat2
   (package
     (name "hisat2")
-    (version "2.0.5")
+    (version "2.2.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "ftp://ftp.ccb.jhu.edu/pub/infphilo/hisat2"
-                           "/downloads/hisat2-" version "-source.zip"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/DaehwanKimLab/hisat2/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0lywnr8kijwsc2aw10dwxic0n0yvip6fl3rjlvc8zzwahamy4x7g"))))
+         "0lmzdhzjkvxw7n5w40pbv5fgzd4cz0f9pxczswn3d4cr0k10k754"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no check target
@@ -3840,9 +3842,12 @@ particular, reads spanning multiple exons.")
          (add-after 'unpack 'make-deterministic
            (lambda _
              (substitute* "Makefile"
-               (("`date`") "0"))
-             #t))
+               (("`date`") "0"))))
          (delete 'configure)
+         (add-before 'build 'build-manual
+           (lambda _
+             (mkdir-p "doc")
+             (invoke "make" "doc")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -3853,13 +3858,13 @@ particular, reads spanning multiple exons.")
                 (find-files "."
                             "hisat2(-(build|align|inspect)(-(s|l)(-debug)*)*)*$"))
                (mkdir-p doc)
-               (install-file "doc/manual.inc.html" doc))
-             #t)))))
+               (install-file "doc/manual.inc.html" doc)))))))
     (native-inputs
-     `(("unzip" ,unzip)                 ; needed for archive from ftp
-       ("perl" ,perl)
+     `(("perl" ,perl)
        ("pandoc" ,pandoc)))             ; for documentation
-    (home-page "https://ccb.jhu.edu/software/hisat2/index.shtml")
+    (inputs
+     `(("python" ,python-wrapper)))
+    (home-page "https://daehwankimlab.github.io/hisat2/")
     (synopsis "Graph-based alignment of genomic sequencing reads")
     (description "HISAT2 is a fast and sensitive alignment program for mapping
 next-generation sequencing reads (both DNA and RNA) to a population of human