summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-17 19:06:30 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:39 +0200
commit08d6f7fad94279968e0a72231cb249960038bbdd (patch)
tree31ade40e07a6bec9aad36854181aba41c4566a72
parent2c010c1ba0e7f458623dd61ef99943959bba5874 (diff)
downloadguix-08d6f7fad94279968e0a72231cb249960038bbdd.tar.gz
gnu: emacs-sly-stepper: Remove generated sources.
* gnu/packages/emacs-xyz.scm (sly-stepper)[source]: Add snippet to remove
autoloads.
[#:phases]: Do not delete ‘make-autoloads’ or ‘enable-autoloads-compilation’.
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9567d9aa15..f8762a1b3c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10478,7 +10478,12 @@ inside the source file.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "1hxniaxifdw3m4y4yssgy22xcmmf558wx7rpz66wy5hwybjslf7b"))))
+           "1hxniaxifdw3m4y4yssgy22xcmmf558wx7rpz66wy5hwybjslf7b"))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             (map delete-file (find-files "." ".*-autoloads\\.elc?$"))
+             #t))))
       (build-system emacs-build-system)
       (inputs
        `(("cl-agnostic-lizard" ,cl-agnostic-lizard)))
@@ -10488,9 +10493,6 @@ inside the source file.")
        `(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)
          #:phases
          (modify-phases %standard-phases
-           ;; The package provides autoloads.
-           (delete 'make-autoloads)
-           (delete 'enable-autoloads-compilation)
            (add-after 'expand-load-path 'expand-sly-contrib
              (lambda* (#:key inputs #:allow-other-keys)
                (let* ((sly (assoc-ref inputs "emacs-sly"))